Require perl 5.8.1
authorVincent Pit <vince@profvince.com>
Tue, 18 May 2010 21:21:50 +0000 (23:21 +0200)
committerVincent Pit <vince@profvince.com>
Tue, 18 May 2010 21:21:50 +0000 (23:21 +0200)
5.8.0 seems to cause a lot of "Modification of a a read-only value" errors.

Makefile.PL
lib/indirect.pm

index 39749fc..1f7e5c8 100644 (file)
@@ -1,4 +1,4 @@
-use 5.008;
+use 5.008001;
 
 use strict;
 use warnings;
@@ -56,7 +56,7 @@ WriteMakefile(
  PL_FILES         => {},
  @DEFINES,
  PREREQ_PM        => \%PREREQ_PM,
- MIN_PERL_VERSION => 5.008,
+ MIN_PERL_VERSION => 5.008001,
  META_MERGE       => \%META,
  dist             => {
   PREOP    => "pod2text $file > \$(DISTVNAME)/README",
index 304e70a..b49c702 100644 (file)
@@ -1,6 +1,6 @@
 package indirect;
 
-use 5.008;
+use 5.008001;
 
 use strict;
 use warnings;
@@ -191,7 +191,7 @@ Hence C<my $x = new Class if 0> will be caught.
 
 =head1 DEPENDENCIES
 
-L<perl> 5.8.
+L<perl> 5.8.1.
 
 L<XSLoader> (standard since perl 5.006).