Require Module::ExtractUse 0.24 for the Kwalitee test
[perl/modules/indirect.git] / t / 99-kwalitee.t
1 #!perl
2
3 use strict;
4 use warnings;
5
6 use Test::More;
7
8 eval { require Parse::RecDescent; 'Parse::RecDescent'->VERSION('1.967006') }
9   or plan skip_all => 'Parse::RecDescent version 1.967006 or greater required';
10
11 eval { require Module::ExtractUse; 'Module::ExtractUse'->VERSION('0.24') }
12   or plan skip_all => 'Module::ExtractUse version 0.24 or greater required';
13
14 eval { require Test::Kwalitee; 1 }
15   or plan skip_all => 'Test::Kwalitee required';
16
17 SKIP: {
18  eval { Test::Kwalitee->import(); };
19  if (my $err = $@) {
20   1 while chomp $err;
21   require Test::Builder;
22   my $Test = Test::Builder->new;
23   my $plan = $Test->has_plan;
24   $Test->skip_all($err) if not defined $plan or $plan eq 'no_plan';
25   skip $err => $plan - $Test->current_test;
26  }
27 }